Powered by eUKhost®

Announcement

Collapse
No announcement yet.

ImageMagick 6

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ImageMagick 6

    I would like to ask if you have any plans to upgrade your servers ImageMagik from version 5+ to version 6 or higher. The reason why I ask is because I use vBulletin 3.0 series (vB 3.0.9 to be exact) on your server. But recently I tried to upgrade and install there latest version which is vBulletin 3.5 series as the version I use now will shortly receive no support in the future seeing as there newest version is now vB 3.5 series and not 3.0 series.

    There latest version has a number of new changes and gives you the choice to use both ImageMagik or GD unlike the vB 3.0 series which I currently use that only offered GD only which your server supported no problem. However ImageMagik requires servers have ImageMagik 6 or higher installed to work which your server doesn't have installed.

    I have spoken to your staff using the online chat after seeing it didn't work in the admincp when testing vB 3.5.1 version and was told you have a version of ImageMagik 5 installed which is incompatible with the latest version of vBulletin which requires servers to have ImageMagik 6 installed or higher for it to work.

    Seeing as vBulletin is one of the top most used boards out there. Do you have any plans to upgrade your version of ImageMagik to version 6 so your server is 100% compatible with there latest version of vbulletin so ImageMagik will work?

    PS: Glad to see the new support forum online :P
    File Sharing News

  • #2
    Just got an email back from your support dep to say they have now upgraded the ImageMagick to version 6 on all servers for vBulletin.

    However there now seems to be a problem with ImageMagick FONTS not being detected even though the ImagMagick itself works now. I think this have something to do with the FONTS not being installed that imagemagick needs
    File Sharing News

    Comment


    • #3
      Are you still facing this problem or do you need this to be sorted ? Please reply to your ticket if you need any help for this problem.
      eUKhost - eNlight Cloud Hosting || eUKhost Knowledgebase
      Toll Free : 0808 262 0255 || Skype : mark_ducadi

      Comment


      • #4
        Yes, it seems one of your staff got confused into thinking that the FONTS used by ImageMagick 6 are used to display the fonts and font size in threads.

        You can read on vBulletins website hosting here:
        www. vbulletin.com/forum/showthread.php?t=162053&highlight=imagemagick

        Were they say you have too compile the fonts for image magick first using Ghost script etc before you even install ImageMagick 6 for it to work. The thing is, the latest version of vBulletin now used both GD and ImageMagick now. Unlike before in there earlier version were it just used GD only in version vb3.0 series.

        What this does is it gives you the option to use ImageMagick now instead of GD from the admin panel. This is used for displaying images on the board and also for the CODE REGISTRATION you enter when a person registers with the website hosting. The problem is - while the image magick background image is displayed, Fonts are not displayed on it. So if you choose ImageMagick and a person tried to register with your website hosting. He would not see any code in the image to enter because the fonts used for it are not installed correctly.

        Here is a quote taken from that thread:

        ImageMagick must be compiled with freetype2 support and to use fonts you need to install GhostScript before ImageMagick.
        File Sharing News

        Comment


        • #5
          Hello Gary,

          Please provide me with the ticket number that you had opened for this issue. I'll have someone to respond to your ticket with latest update.

          Regards,
          Mark.
          eUKhost - eNlight Cloud Hosting || eUKhost Knowledgebase
          Toll Free : 0808 262 0255 || Skype : mark_ducadi

          Comment


          • #6
            Ok, I'm not going to bother putting in another support ticket as I'm going to stay with the previous version of vBulletin 3.0 series. So the problem doesn't matter now as vBulletin 3.0 series doesn't use ImageMagick, and instead uses GD only.

            But you do still have an issue though with the FONTS not being installed and compiled proper for ImageMagick 6. And anybody coming on the server using vBulletin (there latest version vB 3.5 series) which requires ImageMagick 6, is going to have problems becuase the fonts are not installed correctly.

            To see this you might be better as a host installing vBulletin 3.5.1 and then you can track and see this issue from the admincp in the main settings were you select to use ImageMagick instead of GD.

            As I only had one licence and removed the test board that was located in a private directory, seeing as my main board uses the lower version of vB 3.0.9 which doesn't use ImageMagick.

            But if anybody else comes on the server now wanting to host vBulletin, there going to be using there latest baby which requires ImageMagick 6 along with the Fonts installed correctly so they are displayed in the reg code box when people register at there website hostings. Which is not being displayed right now if I use vB 3.5.1 with imageMagick used instead of GD.
            File Sharing News

            Comment


            • #7
              Hello Gary,

              This has been sorted as per your request. Please check its functioning from your end or respond to the ticket that you had opened.

              I'll have one of our system admins to respond if you need any more modifications.

              Regards,
              Mark.
              eUKhost - eNlight Cloud Hosting || eUKhost Knowledgebase
              Toll Free : 0808 262 0255 || Skype : mark_ducadi

              Comment


              • #8
                Originally posted by admin
                Hello Gary,

                This has been sorted as per your request. Please check its functioning from your end or respond to the ticket that you had opened.

                I'll have one of our system admins to respond if you need any more modifications.

                Regards,
                Mark.
                OK, I'm going to have to upload another vB 3.5.1 test board then to see if this is fixed. Can I just asked if you compiled and installed the Fonts using Freetype2 before you installed ImagMagick 6 itself. And do you also have GhostScript installed. Because here is a quote taken from vBulletin by one of there head developers.

                ImageMagick must be compiled with freetype2 support and to use fonts you need to install GhostScript before ImageMagick
                File Sharing News

                Comment


                • #9
                  Image magic 6 is preinstalled how interesting….

                  ATB,

                  Matt

                  Comment


                  • #10
                    This is still not installed to work with vBulletin boards correctly.

                    I'm using this path: /usr/local/bin/

                    But as you can see from this image below, while the fonts for imagemagick are being displayed correctly as installed. The imagemagick image shows an "X" instead of displaying an image in the admincp on my test board.

                    File Sharing News

                    Comment


                    • #11
                      Is there any chance of the ImageMagick module being added to Perl? I personally use a Perl based message board, and would find it very handy to have this module installed.

                      For reference: www. imagemagick.org/script/perl-magick.php
                      To err is human, but to really screw up you need a computer.

                      Comment


                      • #12
                        can you tell me why imagemagik has suddenly stopped working. It was working fine these past few weeks. Now I just noticed the image that is displayed in my admincp settings in vBulletin 6.1 for imagemagik has suddenly stopped showing up an image. I have not changed the path from: "/urs/bin/". So I know the path is correct and still the same.

                        I know you have recently been doing some server work and changes after reading the email I got from you earlier this week. It's looking like the changes made might have messed up imagemagik working now for some reason.
                        File Sharing News

                        Comment


                        • #13
                          Hello Gary,

                          Both ImageMagick and GD Library are working fine on the server and I have verified existence of binary for both. ImageMagick binary is located at /usr/bin/convert and you should try giving that path to see if that works or not.

                          Contact us on our helpdesk if problem is still there and you need to sort the problem quickly or else you can reply over here.
                          eUKhost - eNlight Cloud Hosting || eUKhost Knowledgebase
                          Toll Free : 0808 262 0255 || Skype : mark_ducadi

                          Comment


                          • #14
                            i've had reports that ImageMagick has been playing up on the server I'm using. It's showing as being installed but has apparently stopped working in the past couple of weeks, which explained why people were suddenly having problems in registering on my forums.

                            Edit: One quick email later and it seems to be fixed, cheers.
                            Last edited by Eidolon; 25-09-2006, 12:26. Reason: update
                            To err is human, but to really screw up you need a computer.

                            Comment


                            • #15
                              Hello Eidolon,

                              Please let me know the error you are getting. If you can provide with some login details of forum admin section on our helpdesk then our support staff would be able to sort the problem.
                              eUKhost - eNlight Cloud Hosting || eUKhost Knowledgebase
                              Toll Free : 0808 262 0255 || Skype : mark_ducadi

                              Comment

                              ban-img
                              Working...
                              X