Prior to selecting the control panel as plesk for your hosting, please confirm the Operating System selected is amongst the ones mentioned below ::

CentOS 6.x
CloudLinux 6.x
Debian 6.0
Debian 7.0
openSUSE 12.3
RedHat Enterprise Linux 6.x
Ubuntu 12.04 Server LTS
Windows Server 2012

The above operating systems are recommended by Parallels however plesk is also supported on the below operating systems though not highly recommended ::

CentOS 5.x
CloudLinux 5.x
RedHat Enterprise Linux 5.x
Ubuntu 10.04 Server LTS
Windows Server 2008 R2 SP1
Windows Server 2008 SP2

Pre-requisites for Parallels Plesk installation ::

Plesk version which are currently supported are Parallels Plesk 12, Parallels Plesk 11 and Parallels Plesk 10. With Linux platform, it needs atleast 512 MB of RAM and 1 GB when hosting multiple accounts and in Windows 1/2 GB suffices the needs to a workable extend. A static IP Address is required to be configured in the operating system prior to installing plesk.


Regards,
Suzanne Jones.
Attached Files