Powered by eUKhost®

Announcement

Collapse
No announcement yet.

Has available PHP memory been reduced?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Has available PHP memory been reduced?

    One of my unreleased websites hasn't been touched in about six months. I've come back to it recently to find a lot of HTTP 500 errors - not on the HTML / PHP pages themselves but on scripts that are subsequently called. The error is:

    Code:
    (12)Cannot allocate memory: [client <IP address>:39555] couldn't create child process: /opt/suphp/sbin/suphp for /home/<php script>, referer: http://<URL>
    The HTML / PHP script calls other resources such as images, CSS, Javascript etc. as you'd expect. However, some of those supposedly static resources are actually PHP scripts because they need to be built and delivered in a dynamic manner, like this:

    Code:
    page.php
    |-- logo.jpeg [normal static image]
    |-- qr.png [PHP for a dynamic QR code image]
    |-- css.css [PHP for dynamic CSS]
    |-- javascript.js [PHP for dynamic JS]
    I am now finding that while page.php and logo.jpeg work fine, qr.png, css.css and javascript.js intermittently fail with the above error. I understand that each PHP call will attempt to create a new process (four near-simultaneous processes in the example above) but until a few months ago this was not a problem.

    My question is simply: has the available memory for PHP been reduced in the last six months on shared hosting, particularly on euk5.

    I might be able to work around some of the issues here, and I'm not averse to paying more for 'proper' hosting once this website is ready for release, but at the moment I need to understand what has changed, because it isn't the code base.

    Thank you

  • #2
    Hi,

    There have been no recent changes made within your account or on the server. Your account is hosted on a shared server with multi PHP environment and the default PHP memory limit is set to 32 MB for each account.

    However this limit is not fixed and you always have the option to increase PHP memory limit from within cPanel control panel and set it yourself ranging from 32 MB to 128 MB.

    In order to increase this limit, you need to select different PHP version other than the default one by following the steps below

    Login to cPanel >> Select PHP version >> Switch to PHP options >> select Memory Limit.

    You may also contact our technical support team through Live Chat anytime to get this done through them if you do not wish to change it yourself.
    Wordpress Hosting - Your Adventure, Your Story!
    Website Security Bundle - Great Value Security Solutions in value-for-money package!
    Follow eUKhost on Twitter || Join eUKhost Community on Facebook

    Comment


    • #3
      Hi Ryan,

      Thanks for your help. I did up the available memory from (I think) 64MB to the maximum of 128MB but it hasn't helped. Is this per child process, do you know?

      I've also looked at the Details under 'CPU and Concurrent Connection Usage' which shows that a single page load - which results in about 4-5 PHP scripts - takes up only about 256MB of 1GB VM memory but still results in a handful of VMemF errors.

      Do you have any other suggestions for something I can look at or is this best dealt with via Live Chat?

      Thanks again.

      Comment


      • #4
        [Duplicate: deleted]

        Comment


        • #5
          If the memory limit increase didn't help, I think it would be best to initiate a Live Chat so the support can investigate and troubleshoot if necessary.
          Wordpress Hosting - Your Adventure, Your Story!
          Website Security Bundle - Great Value Security Solutions in value-for-money package!
          Follow eUKhost on Twitter || Join eUKhost Community on Facebook

          Comment

          ban-img
          Working...
          X