Announcement

Collapse
No announcement yet.

High server load

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Re: High server load

    Back up but still a bit slow, as it has been all day.

    Comment


    • #17
      Re: High server load

      Originally posted by squidier View Post
      Looks like it's gone down again today.
      Originally posted by squidier View Post
      Back up but still a bit slow, as it has been all day.
      Hi Jane!

      The storage is a bit slow at the moment as the VMs are starting up. We'll keep you posted on the status.
      Rock _a.k.a._ Jack Daniel

      Follow eUKhost on Twitter || Join eUKhost Community on Facebook

      Comment


      • #18
        Re: High server load

        ...and I can't start mysqld

        Originally posted by Rock View Post
        Hi Jane!

        The storage is a bit slow at the moment as the VMs are starting up. We'll keep you posted on the status.

        Comment


        • #19
          Re: High server load

          Any updates? It's been 3 hours now - the service status page says fixing it would take minutes.

          Comment


          • #20
            Re: High server load

            Originally posted by squidier View Post
            ...and I can't start mysqld
            Hi Jane,

            I can see that MySQL is back online now. Please let us know if you see any other problems with the services.
            Rock _a.k.a._ Jack Daniel

            Follow eUKhost on Twitter || Join eUKhost Community on Facebook

            Comment


            • #21
              Re: High server load

              Originally posted by squidier View Post
              Any updates? It's been 3 hours now - the service status page says fixing it would take minutes.
              I've updated the status page. Please let me know if you still see any sluggishness with the servers.
              Rock _a.k.a._ Jack Daniel

              Follow eUKhost on Twitter || Join eUKhost Community on Facebook

              Comment


              • #22
                Re: High server load

                It seems alright at the moment.
                What was the problem?

                Comment


                • #23
                  Re: High server load

                  Originally posted by squidier View Post
                  It seems alright at the moment.
                  What was the problem?
                  Thank you for the confirmation Jane. We'll respond to you on the exact cause behind this.
                  Rock _a.k.a._ Jack Daniel

                  Follow eUKhost on Twitter || Join eUKhost Community on Facebook

                  Comment


                  • #24
                    Re: High server load

                    I've seen a lot of high io wait times recently, this morning it was noticeably worse, live chat were as useless as ever so I logged a ticket to which no one bothered to reply, shortly after logging the ticket VM5 was dead for over an hour, 3 ecom sites down on one of the busiest weeks of the year!

                    All support want to do is log into our VM, that's not going to happen, the issue appeared to be either the network bandwidth to the SAN or the SAN itself, at times we were seeing 99% io wait on 4 cpu cores which threw the load up and jammed the server.

                    It seems to have settled now but as usual its too little too late...

                    This isn't the first time this has happened, if you can't get your act together we'll have to move to something more robust.

                    Comment


                    • #25
                      Re: High server load

                      Again and again we are promised more updates when these things happen - but nothing changes.

                      I believe there may be some sort of hardware upgrades in progress - if that is true, now is the worst time of year for it to go ahead.

                      To make matters worse another server I have with Eukhost has now gone down. Not a good day.


                      Originally posted by woodpecker View Post
                      I've seen a lot of high io wait times recently, this morning it was noticeably worse, live chat were as useless as ever so I logged a ticket to which no one bothered to reply, shortly after logging the ticket VM5 was dead for over an hour, 3 ecom sites down on one of the busiest weeks of the year!

                      All support want to do is log into our VM, that's not going to happen, the issue appeared to be either the network bandwidth to the SAN or the SAN itself, at times we were seeing 99% io wait on 4 cpu cores which threw the load up and jammed the server.

                      It seems to have settled now but as usual its too little too late...

                      This isn't the first time this has happened, if you can't get your act together we'll have to move to something more robust.

                      Comment


                      • #26
                        Re: High server load

                        Originally posted by Rock View Post
                        I've updated the status page. Please let me know if you still see any sluggishness with the servers.
                        My server does some backups overnight and I noticed that it reached very high loads a couple of times during the backup - this only happened very infrequently in the past, it happened 3 times last night.

                        Comment


                        • #27
                          Re: High server load

                          Originally posted by squidier View Post
                          Again and again we are promised more updates when these things happen - but nothing changes.

                          I believe there may be some sort of hardware upgrades in progress - if that is true, now is the worst time of year for it to go ahead.

                          To make matters worse another server I have with Eukhost has now gone down. Not a good day.
                          I think there is a serious issue with the io on VMC5, when the webalizer cron jobs ran at 5am the server just locked with a 1 minute load of 94, this is 4 CPU 10GHz cloud!

                          Time: Wed Dec 2 05:00:17 2015 +0000
                          1 Min Load Avg: 94.72
                          5 Min Load Avg: 31.03
                          15 Min Load Avg: 12.69

                          Also at 2:20 am the server locked solid running an overnight rsync job with crazy loads as below.

                          Time: Wed Dec 2 02:21:06 2015 +0000
                          1 Min Load Avg: 81.26
                          5 Min Load Avg: 70.29
                          15 Min Load Avg: 41.24

                          It looks to me like we are on a crippled or bandwidth limited SAN

                          Comment


                          • #28
                            Re: High server load

                            And the support ticket answer from the clowns in India:-

                            "I'm afraid but we're not able to access your server via SSH"

                            Correct, and you're not having access, the SSH keys you try and install are deleted and the password and ports changed.

                            VMC5 seems to be served from a NodeFour data centre now, is this a recent change?

                            So, EUKhost, what EXACTLY have you done here, we pay extra for an SAS disk upgrade as well!

                            Comment


                            • #29
                              Re: High server load

                              Anyone from EUKhost around?

                              YOU NEED TO FIX THE VMC5 IO PERFORMANCE

                              Here is a test of the super expensive cloud with extra money paid for SAS vs an EUKhost el cheapo VPS

                              VMC5 3 test runs gave a dismal 10.9 / 18.1 /26 MB/s

                              dd if=/dev/zero of=/root/testfile bs=1G count=1 oflag=direct
                              1+0 records in
                              1+0 records out
                              1073741824 bytes (1.1 GB) copied, 98.8213 seconds, 10.9 MB/s

                              Cheapo VPS

                              3 test runs 163 / 309 / 338 MB/s

                              dd if=/dev/zero of=/root/testfile bs=1G count=1 oflag=direct
                              1+0 records in
                              1+0 records out
                              1073741824 bytes (1.1 GB) copied, 3.17711 seconds, 338 MB/s

                              Comment


                              • #30
                                Re: High server load

                                Seems I'm just talking to myself here but this tests the latency by writing 1000 small files, again dismal performance vs the cheap VPS

                                1.5 seconds to complete on the cloud, 0.005 Seconds on the VPS!

                                VMC5

                                [email protected] [/etc]# dd if=/dev/zero of=/root/testfile bs=512 count=1000 oflag=direct
                                1000+0 records in
                                1000+0 records out
                                512000 bytes (512 kB) copied, 2.36528 seconds, 216 kB/s

                                VPS

                                [email protected] [~]# dd if=/dev/zero of=/root/testfile bs=512 count=1000 oflag=direct
                                1000+0 records in
                                1000+0 records out
                                512000 bytes (512 kB) copied, 0.00500516 seconds, 102 MB/s

                                Comment

                                Working...
                                X