Announcement

Collapse
No announcement yet.

Wordpress admin 500 errors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wordpress admin 500 errors

    Hi,
    Last night I had no sleep. It took me 9 hours of frustration so I"m posting this here to help anyone else who has the problem.


    1. I have several sites using Wordpress hosting services
    2. Last night I turned on mod_deflate which compresses files by around 70%, recommended by Google
    3. Rebuilt apache.... then couldn't log into any Wordpress admin areas.
    4. After alot of pain, my last resort was to turn OFF mod_deflate
    5. STILL I get errors.

    By now I was stressed, very stressed. The server was exactly as compiled before the errors so I emailed Eukhost dedicated support guys. Angelo rebuilt apache and all was fine.

    I found out what caused the error.


    - Angelo compiled apache without suhosin php hardening

    - To trace the error I recompiled it again WITH suhosin and the error returned, this proved it was not mod_deflate which caused the error. It was Wordpress 3 and suhosin

    csf firewall says
    Check php for ini_set disabled <<< was not done
    Check php for Suhosin

    Wordpress version 3 has an ini_set in admin.php which tries to change the php memory allocation, and suhosin doesn't allow this = which meant we got a server error on login

    I went to Service Configuration >> PHP Configuration Editor >> advanced mode >> Safe Mode disable_functions

    and added ini_set

    The server error disappears... and security in csf increases

    I'll add this to the forum as I didn't find this information anywhere on the internet last night.
    It might help others,

    Many thanks to Angelo, by recompiling the server without suhosin, highlighted where the problem was. I"d spent 9 hours thinking it was mod_deflate...which was th eobvious culprit as I'd just turned it on.

    Cheers
    Simon
    Cheap international calls from mobile phones >

  • #2
    Hi Simon,

    Thanks for sharing the solution here, would definitely help others suffering from a similar problem Meanwhile, you can find a complete list of PHP's functions which are considered to be dangerous & can be disabled/added safely through the PHP.ini file.. http://www.eukhost.com/forums/f42/di...unctions-6020/
    Rock _a.k.a._ Jack Daniel

    Follow eUKhost on Twitter || Join eUKhost Community on Facebook

    Comment


    • #3
      I had the same problem. All was well using WP 3.0.1, with the problem starting after upgrading to WP 3.0.3.

      As Simon says, adding ini_set to the list of disabled functions in php.ini solves the issue immediately.

      Comment

      Working...
      X