How To Enable My Computer icon on Windows Server 2012 Desktop

  • Filter
  • Time
  • Show
Clear All
new posts

    How To Enable My Computer icon on Windows Server 2012 Desktop

    You can enable the "My Computer" icon on a Windows 2012 server desktop using the below steps :
    1. Go to Server Manager
    2. Click Add Roles and Features
    3. Click Next until you get to the Features section. Check the option "Desktop Experience" under "User Interfaces and Infrastructure"
    4. Click Install
    5. Close the wizard after the installation completes
    6. Restart the system.
    7. Once, the server is online right click the desktop you will see a Personalize option in the menu
    8. Select Change Desktop Icons
    9. Select the icons you would like to see on the desktop and press OK
    10. You will now see the icons on your desktop
    Last edited by Rsync; 25-07-2022, 05:48.
    "It Takes 20 Years To Build A Reputation And Five Minutes To Ruin It. If You Think About That, You'll Do Things Differently. "

    Re: How To Enable My Computer icon on Windows Server 2012 Desktop

    Very useful information......Thanks for sharing...


      Hello @PMagic , Thank you for such information,

      But I really like to add something

      To enable the My Computer icon on the desktop of Windows Server 2012, you can follow these steps:

      Method 1: Using Desktop Icons Settings
      1. Right-click on the desktop and select "Personalize" from the context menu.
      2. In the Personalization window, click on "Change desktop icons" on the left-hand side.
      3. In the Desktop Icon Settings window, you'll see a list of available desktop icons. Check the box next to "Computer" and click "OK" to apply the changes.
      4. The My Computer icon should now appear on your desktop.

      Method 2: Using Group Policy Editor
      1. Press the Windows key + R on your keyboard to open the Run dialog box.
      2. Type "gpedit.msc" and press Enter to open the Group Policy Editor.
      3. In the Group Policy Editor window, navigate to "User Configuration" -> "Administrative Templates" -> "Desktop" in the left-hand pane.
      4. In the right-hand pane, locate the setting named "Remove Computer Icon on the desktop" and double-click on it.
      5. In the settings window, select "Disabled" and click "OK" to save the changes.
      6. Close the Group Policy Editor.
      7. Refresh your desktop, and the My Computer icon should now be visible.

      Note: The Group Policy Editor method is only available in Windows Server editions that have the Group Policy feature installed. If you're using a version that doesn't have it, you can use the first method instead.

      By following either of these methods, you should be able to enable the My Computer icon on your Windows Server 2012 desktop.


        Thanks @PMagic ​for sharing such a useful information and providing detailed explanation