Powered by eUKhost®

Announcement

Collapse
No announcement yet.

PHP 5.2.10 and Prior Versions Multiple Vulnerabilities and PHP Hosting

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP 5.2.10 and Prior Versions Multiple Vulnerabilities and PHP Hosting

    News from securityfocus:

    PHP 5.2.10 and Prior Versions Multiple Vulnerabilities

    PHP is prone to multiple security vulnerabilities.

    The impact of these issues has not been specified. We will update this BID when more information becomes available.

    These issues affect PHP 5.2.10 and prior versions.

    Probably best everyone upgrades ASAP

  • #2
    Hello,

    Cpanel has started providing PHP 5.2.11, so the upgrade is easily available in cpanel.




    Regards,
    Sam
    System Admin

    Comment


    • #3
      Originally posted by eukSam View Post
      Hello,

      Cpanel has started providing PHP 5.2.11, so the upgrade is easily available in cpanel.




      I know it's a reseller server rather than VPS, however I noticed puma is still using PHP 5.2.5.
      To err is human, but to really screw up you need a computer.

      Comment


      • #4
        We cant upgrade php version on puma server, as it will create problem for another site which are hosted on this server. We have another server on which PHP version 5.2.13 is runing, If you wish we will migrate your account on that server. Please confirm PHP 5.2.13 is fine with you ?

        Regards,
        Stuart.

        Comment


        • #5
          Originally posted by Stuart View Post
          We cant upgrade php version on puma server, as it will create problem for another site which are hosted on this server. We have another server on which PHP version 5.2.13 is runing, If you wish we will migrate your account on that server. Please confirm PHP 5.2.13 is fine with you ?

          Regards,
          Stuart.
          Personally I'm fine sticking with puma. I'm just slightly surprised a version with "multiple security vulnerabilities" is still being used considering eukhost have tight security settings in place in general on their servers.

          On a related note 5.2.14 and 5.3.3 have been released, and this is due to be the last 5.2 release according to the PHP.net site.
          To err is human, but to really screw up you need a computer.

          Comment


          • #6
            Just bumping this topic to mention that the PHP 5.3.8 release announcement states...
            All PHP users should note that the PHP 5.2 series is NOT supported anymore. All users are strongly encouraged to upgrade to PHP 5.3.8.
            URL: PHP: News Archive - 2011

            Perhaps eUKhost should consider upgrading PHP on their servers to 5.3 now, as being unsupported it potentially may have security issues. Currently puma still appears to be using version 5.2.9 still, not even the last 5.2 version.
            To err is human, but to really screw up you need a computer.

            Comment


            • #7
              Hi Eidolon.

              Yea, It seems that PHP 5.2 version is no longer supported by PHP.net.
              But the Cpanel still lists the old stable releases as 5.2.9, 5.2.17 in easyapache installer.

              Due to compatibility and other customization issues, we will not able to upgrade the PHP version to 5.3 on the existing shared servers. However we will schedule PHP upgrade to old stable version 5.2.17 in upcoming days
              Regards,
              Kieran A.
              Cloud Administrator
              Skype :: Kieran.Alen | eUKhost

              Comment


              • #8
                Re: PHP 5.2.10 and Prior Versions Multiple Vulnerabilities and PHP Hosting

                @ trololo444

                You are digging an old grave and the worst part is you are digging it wrongly Care to explain the reason behind sharing URL.

                Comment

                ban-img
                Working...
                X