Scheduled task not working as desired.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Scheduled task not working as desired.

    Hi,

    I have Windows server 2003 dedicated server on which I have created some schedule task through Plesk control panel. Everything was working fine until few days ago and the Crons were executing automatically as per the schedule. All of sudden the scheduled task stopped executing automatically. I have tried to execute the task manually through Plesk control panel and I am able to execute it. But they are not executing automatically.

    Can you please help me to get this sorted out.

    Regards,
    Rummy.

    #2
    Re: Scheduled task not working as desired.

    Hi,

    Can you go through the server logs to check if you receive any error message ? You can also try deleting and then recreating the tasks again to see it it works !!
    "It Takes 20 Years To Build A Reputation And Five Minutes To Ruin It. If You Think About That, You'll Do Things Differently. "

    Comment


      #3
      Re: Scheduled task not working as desired.

      Hi,

      I have already tried to re-create it but still getting the same error. I have gone through the server logs and I found below error -

      SchedulerManager::set() failed: crontabmng failed: Unable to restore user scheduler: System.Runtime.InteropServices.COMException (0x80090016): Keyset does not exist (Exception from HRESULT: 0x80090016)

      Regards,
      Rummy

      Comment


        #4
        Re: Scheduled task not working as desired.

        Originally posted by rummy View Post
        Hi,

        SchedulerManager::set() failed: crontabmng failed: Unable to restore user scheduler: System.Runtime.InteropServices.COMException (0x80090016): Keyset does not exist (Exception from HRESULT: 0x80090016)
        Hi Rummy,

        Seems, there is some issue with the “Cryptographic Services" and the local system private keys used by the service got corrupted.
        You can follow the below steps to resolve this issue :

        - Stop the “Cryptographic Services” service.
        - Go to My Computer -->> Tools Menu -->> Folder Options
        - On the “View” tab, Click “Show hidden files and folders” ->> Click Ok.
        - Go to “C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\S-1-5-18″ folder.
        - Delete all the files present under the "S-1-5-18" folder.
        - Restart the “Cryptographic Services” service.

        Note : You might need to give the user’s password for each task after performing the steps above.
        "It Takes 20 Years To Build A Reputation And Five Minutes To Ruin It. If You Think About That, You'll Do Things Differently. "

        Comment


          #5
          Re: Scheduled task not working as desired.

          Hmmm,

          Some deep investigation done by Pmagic on this issue & found the solution. Goo work Bro!!

          This will surely help who faced or if they will face this issue .

          Thanks for sharing this


          Regards,
          Popeye

          The Sailor Man

          Comment

          Working...
          X