Setting up domain name for vps

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Setting up domain name for vps

    Hi,
    I am currently attempting to setup my domain name which I have registered with eukhost and my centos vps which i can access fine via the ip address. The nameservers on the config page (and in the whois information for the domain) are those which were sent to me in the welcome email but when i type the address in it times out.

    I have tried doing a lookup on the domain but this is all i got:
    Source TTL Address Type Record Type1 Resolution
    langtreeshout.org. 0 IN A 67.215.66.132

    The ip of the server is 213.175.199.220. I don't know whether I need to setup BIND creating on my server or whether it is some other issue. My server also does not have cpanel or any bundled control panel on it but I have installed webmin.

    Thanks,
    Tom Wright

    #2
    Hello Tom,

    I have checked your VPS and unable to find the zone file of the domain. So, please create the zone file of the domain OR add it from webmin control panel.

    Kindly let us know if we can further assist you.
    vzAddict || Mike :cool:

    eUKHost on ||

    Comment


      #3
      Hi,
      sorry I was cut off in live chat (I somehow lost the browser window), I am slightly unsure what settings I need to use for the zone (do i need too specify the master server as on my vps or the ones from the welcome email)? I have been googleing for a good tutorial covering this to no avail :frown:. A sample version of the zone file would be great. Edit: I am looking at the documentation now but still confused asto how to set it up for this case

      Thanks once again for your help,
      Tom Wright
      Last edited by twright; 06-03-2009, 23:30.

      Comment


        #4
        Hello,

        It seems that you have created the zone file for the domain as I can see the zone on the VPS. I have corrected domain.com.hosts file and now DNS is configured properly.

        Kindly let us know if we can further assist you.
        vzAddict || Mike :cool:

        eUKHost on ||

        Comment


          #5
          Originally posted by vzAddict View Post
          Hello,

          It seems that you have created the zone file for the domain as I can see the zone on the VPS. I have corrected domain.com.hosts file and now DNS is configured properly.

          Kindly let us know if we can further assist you.
          thanks, you have been a great help in setting this up (I will probably be heading to the user testimonials forum next :smile, just one question should I chown the file so it is owned by named like all of the other zone files? I have just checked and it works perfectly. Finally, if you need to connect to the server again can you use the account support (the password is the same).

          Comment


            #6
            Originally posted by twright View Post
            just one question should I chown the file so it is owned by named like all of the other zone files?
            Yes, you'd need to change the ownership of that zone file to root.named as the rest

            The exact steps involving into this would be :

            1) Login to SSH as root.
            2) cd /var/named/
            3) chown root.named domain.com.db [where domain.com is your actual domain]

            Do get back if you have any further questions.. Good luck & have a peaceful weekend
            Last edited by Rock; 07-03-2009, 03:47. Reason: corrections :)
            Rock _a.k.a._ Jack Daniel

            Follow eUKhost on Twitter || Join eUKhost Community on Facebook

            Comment


              #7
              Originally posted by Rock View Post
              Yes, you'd need to change the ownership of that zone file to root.named as the rest

              The exact steps involving into this would be :

              1) Login to SSH as root.
              2) cd /var/named/
              3) chown root.named domain.com.db [where domain.com is your actual domain]

              Do get back if you have any further questions.. Good luck & have a peaceful weekend
              The rest seem to be root:named, so i have chowned it accordingly. Anyway it seems to work great now so it's fine

              Comment

              Working...
              X