Announcement

Collapse
No announcement yet.

ImageMagick issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ImageMagick issues

    Having issues with using imagemagick to, well, do anything really. I know that it's installed on the server and working (thanks to support who installed singapore image gallery) but I just can't get it to work in any of my scripts.

    I've setup a test script and stripped it right down to the basics.

    Code:
    $command = "/usr/bin/convert realtennis.jpg realtennis.gif";
    $response = `$command`;
    Which should just simply convert the jpg to a gif. But nothing happens. I've use this script sooooo many times in the past on different hosting with no issues at all. I'm assured that /usr/bin is the correct path the imagemagick, hell I've even tried it without...

    If anyone can shed any light on where I'm going wrong here....?

    For adminns ref: script is at http://www.canfordrealtennis.co.uk/temp.php

  • #2
    I've been informed by someone of the following...

    Image::Magick bug
    There is a bug in PerlMagick' s QueryFontMetrics() method. ImageMagick versions smaller than 6.0.4 is affected. Below text is from the ImageMagick 6.0.4 Changelog: www. imagemagick.org/www/Changelog.html

    "2004-05-06 PerlMagick's QueryFontMetrics() incorrectly reports `unrecognized attribute'` for the `font' attribute."

    Please upgrade to ImageMagick 6.0.4 or any newer version, if your ImageMagick version is smaller than 6.0.4 and you want to use Image::Magick as the backend for GD::SecurityImage.
    What version are eUKHost using as this could be the problem. I'm aware some dev guys on my board are 'ripping their hair out' as it doesn't seem to be working for them, though I've got it to work with a forum software.
    To err is human, but to really screw up you need a computer.

    Comment


    • #3
      We have Version: ImageMagick 6.0.7 on all our servers.
      eUKhost - eNlight Cloud Hosting || eUKhost Knowledgebase
      Toll Free : 0808 262 0255 || Skype : mark_ducadi

      Comment


      • #4
        EDIT:

        Sorry just re-checked my admincp in vBulletin. It appears to be working fine now
        Last edited by MRGTB; 01-10-2006, 10:09.
        File Sharing News

        Comment


        • #5
          Image magick installation in Linux

          Hi,

          I was trying to install Image Magick in a linux server I have uploaded all the files to a folder in the server using FTP and accessed it through putty. When I tried ./configure it displayed permission denied then I set chmod 555 configure after that when I tried ./configure it displayed No such file or directory.

          Image magick version - 6.2.6

          Please help me to solve this issue.

          Thanks
          Sudheshna K

          Comment


          • #6
            Install it using rpm source. If you have cpanel server then you can run following command to install Image::Magick


            /scripts/realperlinstaller Image::Magick
            eUKhost - eNlight Cloud Hosting || eUKhost Knowledgebase
            Toll Free : 0808 262 0255 || Skype : mark_ducadi

            Comment


            • #7
              Hi All,
              It is highly advised that you post your corresponding phpinfo file so that others can review various things about your problem or configuration. Guessing games take longer and somtimes it eventually comes out to be a O instead of an 0!

              Regds
              IJ

              Comment


              • #8
                Do you have root access Sudheshna? are you on a VPS Hosting?

                Comment

                Working...
                X