Announcement

Collapse
No announcement yet.

Problem with Server?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Server?

    I use a private form, which I have been doing so for sucessfully for months on my website (account Ultan Art Website).

    Suddenly today any time I submit the chunk of text using POST it keeps returning a 404, if i submit a "smaller" chunk of text it works properly?

    Has any settings changed on the Server for processing time or something?

  • #2
    Yeh it's definately something weird going on, I can submit about 5 lines of text and it works everytime, anything above that fails.

    Something been changed ?

    Guess it could also be my connection?
    Last edited by Pickled; 28-08-2008, 19:39.

    Comment


    • #3
      Has any settings changed on the Server for processing time or something?
      Nope there wasn't any such changes made on server.
      Also, I am not getting any such 404 errors for your domain under servers error_logs.

      Please update me with the exact method to reproduce the error, I will investigate it further.

      Nick J.

      Comment


      • #4
        Hello Martin,

        I tried posting a long text(the same question you asked in this forum) on your contact form and it worked without any error.

        Nick J.

        Comment


        • #5
          Could you be so kind as to try it again with like 100 lines of crap....

          When I do that I get a "DNS IE frame error" pop up, if i put in about 5 lines it's fine?!

          Edit* hmmm I think it may be my crappy ADSL line BT just installed
          Last edited by Pickled; 28-08-2008, 20:07.

          Comment


          • #6
            Firefox reports connection refused when sending more than (100 lines of text or so)....

            Guess it could be some filter BT have
            Last edited by Pickled; 28-08-2008, 20:33.

            Comment


            • #7
              Ok tested it at work and no problem there... BT suck badly..

              Comment


              • #8
                Originally posted by Pickled View Post
                Ok tested it at work and no problem there... BT suck badly..
                Its nice to know that you are able to use it without any error

                Nick J.

                Comment


                • #9
                  Ok Nick, sorry to be a pest - but ive done some more testing at work today and i'm actually getting the problem here too when pasting this for example:

                  You try it too with this junk...

                  :frown:

                  Code:
                  Name: asdfasdf
                  Email: [email protected]
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfv
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfv
                  v
                  v
                  v
                  vasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  
                  vasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  
                  vasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfv
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfvasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  
                  vasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf
                  
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfv
                  
                  asdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdfasdfasdf asdf asdf asdf asdf asdfasd fasdf asdfasdf asdfasd 
                  asdfasdfasdfasdf

                  Comment


                  • #10
                    Ok I did some debugging with php streams to figure out what the server was returning when sending the above junk (note that it DOES work when only sending about 10 lines ok) here is what your webserver is returning when sending the above junk:

                    Code:
                    HTTP/1.1 302 Found Date: Fri, 29 Aug 2008 13:10:47 GMT Server: Microsoft-IIS/6.0 Location: http://localhost/removecookies Connection: close Transfer-Encoding: chunked Content-Type: text/html; charset=iso-8859-1 11b 
                    Found
                    The document has moved here.
                    
                    
                    --------------------------------------------------------------------------------
                    http://localhost/removecookies?

                    Apparently the server is automatcially trying to redirect me when sending a lot of data (this was never a problem until about 2 days ago - my code has never changed in years)

                    Doing a google search on this message reveals that it's the webserver settings protecting itself - so you obviously have changed a setting somewhere that does not like a certain amount of post data going through..

                    PS I've tested this on my other content site and that has the same problem (hosted on the same server) with the HTTP:302 redir on posting above x amount of bytes in a form!
                    Last edited by Pickled; 29-08-2008, 13:36.

                    Comment


                    • #11
                      There is someone with a similar problem with EUKHosting a while back I found on google while trying to figure out this annoying problem - I can't update any content!!


                      Joomla! &bull; View topic - Possible problem with editing content which contains "onmouseover"/"onmouseout"? <---weblink


                      url. Who are you hosting with incidentally?devilman
                      Joomla! Apprentice


                      Posts: 9
                      Joined: Fri Apr 14, 2006 2:24 pm Top
                      --------------------------------------------------------------------------------

                      Re: Possible problem with editing content which contains "onmouseover"/"onmouseo
                      by liviutudor on Tue Jan 30, 2007 2:08 pm

                      eukhost.com -- ....

                      Comment


                      • #12
                        Ok upon further investigations on a Wiki - I have fixed it myself by overiding some server settings in the .htaccess file:

                        SecFilterScanPOST Off (allows me to use POST forms properly now)

                        hmmmmm...

                        What is mod security and how does it affect me - MODx Wiki

                        Comment


                        • #13
                          Can somebody from eukhost confirm that some change has been made. I had noticed this myself and thought it might had been something I had done until I saw this thread.

                          Have been tweaking scripts for ages seeing whether it makes any change but having now seen Picked's post, that seems to have solved it for me also.

                          Does anybody know is something has been changed??

                          Comment


                          • #14
                            I've also noticed that all my POSTs are failing, while GETs are ok. What needs to go into php.ini or .httaccess to override whatever setting was changed?

                            Comment


                            • #15
                              Originally posted by dearsina View Post
                              I've also noticed that all my POSTs are failing, while GETs are ok. What needs to go into php.ini or .httaccess to override whatever setting was changed?
                              Please place this code in the .htaccess of your account, it'd completely disable Mod Security scanning for your account..

                              <IfModule mod_security.c>
                              SecFilterEngine Off
                              SecFilterScanPOST Off
                              SecFlterCheckURLEncoding Off
                              </IfModule>
                              **Note: Disabling mod_sec is harmful for the integrity of your account & can cause severe security related issues for the website..
                              Rock _a.k.a._ Jack Daniel

                              Follow eUKhost on Twitter || Join eUKhost Community on Facebook

                              Comment

                              Working...
                              X