Announcement

Collapse
No announcement yet.

PHP strangest error i've ever seen

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP strangest error i've ever seen

    Ok, i have witness the most unusual (logic error) in php ever but i am unsure if its because of my Linux server getting confused with my method of php.

    It used to work on local host but then everything changed on this server. Sadly I do not know what is causing this problem or how logically it could occur in the first place so i can only explain what is happening then your as well informed as me on my own problem here.


    Basically i have a page which includes a file lets say called A this A file then includes another file called A2.

    Now its Main inc > A inc > A2

    On A2 firstly the result on the script comes out as a standard error i put in when the if statement fails... but for last 3 days it was working fine.

    But as it went wrong i decided to find out what went wrong so i added random chars down the script to see which if statements the script when into.. now when i saved the file (and i checked my directory it did save it and it currently is still there), even though i edited the html....on my browser when viewing the page, the html didn't change at all.. no added characters appeared it was like i never edited the script.

    So then some one said it might be memory cached but ALL my other scripts update instantly except this one script which will not change... even on line 1 i put die; and the script would not die! how ever the script is being included and read otherwise there would be no output but there is, because around line 400 odd it echo's the table..

    Imagine this as the script:
    1: die; // this is skipped and is new to the script added in less than one day ago
    .// echo error here if user failed validation (this displays and is not new to the script)
    .
    413: // table here (this displays and is not new to the script)


    It shows the outputs, but skips the die which just well logically this makes no sense so my only guess is Linux is not reading php properly some how..due to only recent events and only on this one script...

    So yeah im really desperate for some one to theorize a suggestion for me to figure out this problem, because I'm totally out of ideas.
    Last edited by SirChick; 31-08-2008, 23:17.

  • #2
    Have you placed a ticket for this..? If yes, then do let us know the ID.

    We will not be able to help unless we know your account details and the location of your files.
    Martin
    Chief R & D Officer.

    - -

    Comment


    • #3
      Ok, sorry didn't know that, shall make a ticket

      Comment


      • #4
        Hii..

        Did you manage to get this sorted.. Please let us know the ticket ID if it is still unresolved.
        Martin
        Chief R & D Officer.

        - -

        Comment


        • #5
          Yes i had it sorted, i had to remove the include having an include which for some reason the server did not agree with, so i had to change the structure and now it works smoothly. Thank you!

          Comment


          • #6
            Thank you for keeping us updated.
            We are glad it has been sorted.
            Martin
            Chief R & D Officer.

            - -

            Comment

            Working...
            X