Powered by eUKhost®

Announcement

Collapse
No announcement yet.

Wrong version of Rails error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wrong version of Rails error

    Hello.

    I'm a beginner at Rails. I've a shared server with Ruby etc, & Rails is installed. When I go to cpanel > RoR > create, I get:

    Your app is NOT installed because there was a problem. Try again or contact our support team.

    Show Details
    Rails version 0.6.0 is installed. However, version 2.3.14 is required. Please contact your web hosting provider to have Rails updated.
    This is very odd - the Rails gem is 2.3.12. I've reinstalled it, to no effect. I'm tempted to uninstall it & reinstall, but "first do no harm", so I haven't.

    What does this error mean? I haven't raised a ticket 'cos I'm pretty sure it's something obvious I haven't done, and, well, I got my pride. Any ideas, anyone?

    Robert

  • #2
    Dear Robert.

    As the server can have multiple versions of rails, release 2.3.14 has been installed for you.
    You should able to create your app now.

    [email protected] [/home/tenantry]# gem list --local | grep -i rails
    jrails (0.6.0)
    rails (2.3.14, 2.3.12)
    Regards,
    Kieran A.
    Cloud Administrator
    Skype :: Kieran.Alen | eUKhost

    Comment


    • #3
      Originally posted by Kieran View Post
      Dear Robert.

      As the server can have multiple versions of rails, release 2.3.14 has been installed for you.
      You should able to create your app now.
      Hey, great, Kieran - now creates fine, & "you are riding ror" displays. Another brilliant job! (& I didn't even give you my details - doubly impressive!)

      Comment

      ban-img
      Working...
      X